For ALL your Audi Motorsport Information- regardless of series, cars or Country!
Audifans.net: Audi Forums

www.audifans.net :: View topic - electric issues?
 
 Forum FAQForum FAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
View next topic
View previous topic
Post new topic   Reply to topic
Author Message
xbj9000
Newbie
Newbie



Joined: Aug 19, 2012
Posts: 1
Location: Tennessee, USA

PostPosted: Sun Aug 19, 2012 8:26 pm Reply with quote Back to top

Hi everyone, first post, hoping for some advice..

About 2 weeks ago, after work, I started my Coupe GT (2.3/NG) and my dash didn't light up.. the backlight was on but no data.. (I have the digital dash).. For the next day and a half, it would sometimes come back on while driving, and light up every possible LED for a few seconds and then appear to work normally, but freeze (I would stop at a light and still have a reading of 30mph).. Then it would go blank again.. During this time my MPG average meter would not be reset, and my old data was still there.. Then my data did get reset, and the dash has not gone back out for at least a week.. In addition to my MPG being reset, my fuel gauge went to full and then gradually re-adjusted to about 1/4 (which was the correct reading)..

It had rained the day this started, if that means anything (it has rained much harder recently with no issues, but there is a crack in my fusebox cover which is sealed with some aging duct-tape)..

I have also noticed for a couple of weeks that sometimes when leaving a light I will hear a LOT of ping, until I mash the gas down hard.. This doesn't happen often, and usually it runs normally.. I also felt like it was doing a tiny bit of lurching/surging one time while I was coasting with no throttle.. A single time, after driving, I put it in park and noticed it idled at around 1,600 rpm, instead of the usual 1,000.. It idled normally when I put it back in drive, but then high again when I went back to park..

I found a list of ECU CEL blink codes for similar models, but none specific to the Coupe or NG motor.. I put a fuse in and did the blink test, and I'm pretty sure I got only one error -- "full throttle switch" (2123)..

As far as I know, the full-throttle switch simply causes the system to bypass the O2 sensor and run rich.. I let the car idle while pressing the switch and there was no change at all.. I also played with the switch while holding it at around 2,000 rpm..

So.... do you think the switch is bad, or the O2 sensor?. or could the actual computer be going out, since I also had those problems with the instrument cluster?. Or could it be the knock-sensor even?. I don't see how running rich at low throttle could possibly cause ping, if the switch is stuck 'on', and if it's stuck 'off' then I would expect to get ping at full-throttle, which I haven't experienced..

Thanks in advance..

_________________
1987 Coupe GT, 2.3/NG automatic 
View user's profile Send private message
audioc
Site OWNER



Joined: Jan 17, 2003
Posts: 12502
Location: E Bay?

PostPosted: Thu Aug 23, 2012 10:45 am Reply with quote Back to top

Welcome to the site Cool

Lots of issues; first thing I would do is check the fuse box- remove fuses/ relays and check for corrosion.

Also remove the binnacle and ensure all the contacts are good- one of the multiplug connectors could be loose? Also, is there a voltage regulator on these that provides the correct voltages to the binnacle? This may be going AWOL (not uncommon on the newer cars)

We never had the NG fitted over here in the series 2 Coupe, so it's a case of trying to advise on what I/ others know about the series 2 (we didn't get it with digital dash either), the digital dash, and the NG engine. The fuse box with a split lid sounds like a likely candidate though....

_________________
Don\'t forget: Twitter- www.twitter.com/audifansdotnet
Facebook - www.facebook.com/audifans.net
Free \"Audi\" Newsletter: http://www.audifans.net/downloads-cat6.html 
View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:       
Post new topic   Reply to topic

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Forums ©